AN Forums

Anime Network Subscriptions Thread


#423

I want to know why my subcription changed? I have been a paying member of this site for almost a year now and I’m getting status changed from Premium to Registered?


#424

Anyone have an idea when subscrition be up and running try 5 to 6 times and it still not working


#425

I entered my CC info several times and it always tells me there’s a problem creating the subscription and to try again later right after I click purchase and confirm the subscription. I have no problem using it to buy on other online sites. Can someone please help me?


#426

Reported.


#427

Hi,

Everytime I try and subscribe for premium content, I get the below message -

“There was a problem creating your subscription. Please try again later. If this problem persists please contact the Anime Network”

Can anyone help please…

Thanks.


#428

[quote=“chet32” post=128902]Hi,

Everytime I try and subscribe for premium content, I get the below message -

“There was a problem creating your subscription. Please try again later. If this problem persists please contact the Anime Network”

Can anyone help please…

Thanks.[/quote]

I answered in the other thread - Reported.


#429

Hello, I subscribed through itunes several months ago and I can’t access the premium content anymore. I sent an email about a week ago, however I have not been given a response. I would appreciate any help :slight_smile:


#430

Greetings,

I signed up for a yearly subscription back on December 11, 2011 via my iPod touch. It worked great until June 2012. Somehow, I am no longer recognized as subscriber on both the website nor on my iPod. I tried contacting subscriptions@theanimenetwork.com several times but never received a response. Reading through the forums, this seems to be a prevalent issue. Any help will be greatly appreciated.


#431

I just updated my free subscription to a monthly subscription (premium) on my mobile iPad and iPhone. However I’m still being recognized as a free member and I’m locked out of many of the anime shows. Can this be fixed? Thank you


#432

I subscribed through iTunes and have been charged twice even though my app won’t work. It won’t let me view premium content. I am unable to watch shows because, on my iPhone 4s, will show a message that says “Missing Media” or “Not Available” whenever I click on an episode beyond the first two or so. I am confused as to what exactly I’m paying for here. I have emailed customer service repeatedly but with no reply. I have also given up and tried to cancel by following the directions given on the website and emailing the correct address with no success. I’m deeply disappointed. How can I fix this? I have consulted iTunes and am one day away from contacting the Better Business Bureau.


#433

hi there wonder whats going on try a few day to subscride to u guy’s but keep geting There was a problem creating your subscription. Please try again later. If this problem persists please contact the Anime Network


#434

When are monthly and annual subscribers charged? The first day of either period?


#435

Sad to still have unresolved issues related to accessing premium content or to pay for accessing the VOD at Anime Network… :frowning: Been more than a few months and a lot of emails leading to this point of frustration.


#436

PREMIUM BACK TO REGISTER MEMBER can’t watch any shows fully and hope my account is fix soon thxs :frowning:


#437

I would not get your hopes up. They still have not fixed the issue with subs. And for all my multitude of emails and forum posts I have only received this reply…

14 days ago…

"Thanks. This may have to do with a looping error we are getting. We are working on that this week and should have an answer for you by then. Thanks.

-AN Subscriptions "

It took weeks to even get this much of a response.

By the way this problem with their subscription service has been going on now for months.


#438

I signed up for a premium membership on November 4th, and am now down to just Registered and can’t watch anything. When I try my app, it says I’m a guest user. I’m incredibly frustrated especially since this is a service I’m paying for and I’ve had multiple issues in the first month.


#439

I’m located in Canada and want to take advantage of the 10% Thanksgiving sale on this site.

In the billing information for my credit card, I select “Canada” for country.
But for State/Province in the credit card address, there’s no Canadian provinces listed–only American states.

Also I’ve tried to make a payment, and I get a revolving circle, which then disappears
with no error message. Nothing is showing in my subscription history. It doesn’t
appear as though I’ve been able to subscribe.

I’ve tried making a payment multiple times.

My credit card better not have been charged multiple times.


#440

Hey, I’ve been trying to subscribe, but I don’t seem to be able to enter my credit card info. After I click quarterly plan, 5 words pop up (Select, Type, Card, Expiration Date, Actions) but the only thing that i can click is “Enter Payment Method” and that send me to an error. Were can I buy my subscription?


#441

All of the above have been reported to Admin.


#442

[quote=“Slooshy” post=129624]
Also I’ve tried to make a payment, and I get a revolving circle, which then disappears
with no error message. Nothing is showing in my subscription history. It doesn’t
appear as though I’ve been able to subscribe.

I’ve tried making a payment multiple times.

My credit card better not have been charged multiple times.[/quote]

I’m getting the same problem and I too better not have been charged multiple times.