AN Forums

ANO Technical Support & Customer Service


#21

@a_mailbox
The staff is out for the Labor Day weekend, but may stop in sometime to check this thread.

  • Could you please list some of the anime you tried to watch?
  • What OS & Browser are you using?
  • If you’re getting any error messages, please post a screenshot.

This will help them solve your problem faster.

Thanks for your report!


#22

Ok I’ll answer those in order:

1: Some of the anime I have tried are:
-My Love Story!!
-High School of the dead
-The Familiar of Zero (Season 1)

2:
OS: Windows 10
Browser: Chrome 64bit (I have also tried Microsoft Edge with the same affect.)
(in case it is necessary, My region is BC, Canada)

3:
I’m not getting error messages, rather when entering a “Guest” episode I am greated with the Premium content screen that appears when trying to watch “Premium” episodes. The difference (it seems) is that the URL is different compared to when clicking on a “Premium” episode.

With a premium episode, i get something like this as the URL:

https://www.theanimenetwork.com/Watch-Anime/My-Love-Story/0/17/PayWall/jp/en?NoFreeSub

Which seems right, but with a Guest episode I get this:

https://www.theanimenetwork.com/Watch-Anime/My-Love-Story/0/1/PayWall/jp/en?BadRegion

Which has only happened after the site change.

Thank you for you’re help and I will come back to this thread after the weekend.


#23

OS: Windows 7
I don’t have Chrome installed, just Firefox and Internet Explorer 11.0.22 and I almost exclusively use Firefox. I hadn’t tried IE yet when I posted, so just Firefox at that point. I did access the site thru IE this morning and so far I have not been logged out at all after having gone to several sections. Also though, in Firefox, the logout issue seems random, I’ve browsed a few pages within the site today and haven’t been logged out, which is definitely not how it was behaving a few days ago. I haven’t changed anything since my initial post; however, i do know my computer did an automatic update from windows since then.

The only time I got logged out of the site, without clicking logout, using IE today was when I completely closed IE and went back to the site, which is perfectly acceptable. I’ll continue to work with both IE and Firefox over the next few days to see if I can gather any additional information that might be helpful…


#24

I have similar problems as other have already mentioned : I can’t seem to stay logged in and I can’t watch a single show without being forward to the Premium online subscription / two-weeks trial page with the “Bad Region” url.

Currently running Mac OS X with Safari 7.1.8.

If I log in, I can be logged out by the next page. – and If I can stay logged in and I’m browsing through the shows, i’ll eventually hit the wall whenever I try to watch something. I modified my preferences and accepting all cookies but it doesn’t do anything.

I did a test with several shows and the only content i’m able to watch are trailers. Movies ( ex.: Ninja Scroll ) are marked as “Premium” and forwards me to the “Pay Wall / No Free Sub” page – good. However, all shows are marked as “Guest”, regardless if they’re subbed or dubbed, and I’m forwarded to the "Pay Wall / Bad Region " page.

In the old layout, it would usually be " subs for Guests, dubs for Premium" . So if I would watch something like, say Golgo 13 subbed, it wouldn’t be a problem. Now, I can’t watch anything. Maybe they’re only problems for Guests, and those who have a Premium subscription don’t have them.

Let me know if I can provide any more details.


#25

I love the new design but there’s a huge problem with viewers in Canada since we don’t have Hulu here…
I haven’t been using the website lately but I’ve been wanting to re watch Clannad.

I don’t want to have to use a proxy to get past the block and I hope you’ll find a better way to display ads


#26

I am also having problems with being logged out at random as well now the player control bar isn’t disappearing during play. Also on occasion when logging back in I will get the following error msg:

Server Error in ‘/’ Application.

Object reference not set to an instance of an object.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[NullReferenceException: Object reference not set to an instance of an object.]
AspNet.Identity.MySQL.MySQLDatabase.Query(String commandText, Dictionary2 parameters) +585 AspNet.Identity.MySQL.UserStore.FindByIdAsync(String userId) +141 Microsoft.AspNet.Identity.<GetRolesAsync>d__ac.MoveNext() +216 System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task) +144 System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) +84 System.Runtime.CompilerServices.TaskAwaiter1.GetResult() +49
Microsoft.AspNet.Identity.CultureAwaiter1.GetResult() +109 Microsoft.AspNet.Identity.<CreateAsync>d__0.MoveNext() +1875 System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task) +144 System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) +84 System.Runtime.CompilerServices.TaskAwaiter1.GetResult() +49
sso.theanimenetwork.com.Controllers.d__4.MoveNext() +505
System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task) +144
System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) +84
sso.theanimenetwork.com.Controllers.d__8.MoveNext() +740
System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task) +144
System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) +84
sso.theanimenetwork.com.Controllers.d__22.MoveNext() +587
System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task) +144
System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) +84
System.Web.Mvc.Async.TaskAsyncActionDescriptor.EndExecute(IAsyncResult asyncResult) +143
System.Web.Mvc.Async.<>c__DisplayClass37.b__36(IAsyncResult asyncResult) +23
System.Web.Mvc.Async.AsyncInvocationWithFilters.b__3d() +115
System.Web.Mvc.Async.<>c__DisplayClass46.b__3f() +473
System.Web.Mvc.Async.<>c__DisplayClass33.b__32(IAsyncResult asyncResult) +15
System.Web.Mvc.Async.<>c__DisplayClass2b.b__1c() +32
System.Web.Mvc.Async.<>c__DisplayClass21.b__1e(IAsyncResult asyncResult) +231
System.Web.Mvc.Controller.b__1d(IAsyncResult asyncResult, ExecuteCoreState innerState) +32
System.Web.Mvc.Async.WrappedAsyncVoid1.CallEndDelegate(IAsyncResult asyncResult) +111 System.Web.Mvc.Controller.EndExecuteCore(IAsyncResult asyncResult) +53 System.Web.Mvc.Async.WrappedAsyncVoid1.CallEndDelegate(IAsyncResult asyncResult) +19
System.Web.Mvc.MvcHandler.b__5(IAsyncResult asyncResult, ProcessRequestState innerState) +54
System.Web.Mvc.Async.WrappedAsyncVoid`1.CallEndDelegate(IAsyncResult asyncResult) +111
System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +606
System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +288

I am using google chrome and running on windows 7


#27

Now it’s really difficult to get a stable log in. I just managed to get a log in to ‘stick’ long enough to reply in the forum. But, out on the main site, as soon as I navigate away from the log in result page, the status bar across the top of the page indicates I’m no longer logged in. Because of this, I cannot watch any premium content. This log in problem has been pretty regular since the web site redesign. I know you guys are still working hard debugging stuff, but I wanted to let you know that there’s still users out here who can’t log in to the web site.

Keep up the hard work!


#28

I finally got google chrome, with windows 10. i also got a google app that forces the web player to use html5. now i can watch the videos properly. i still get booted randomly, which is annoying, but it’s better than it was. this also seems to happen when i’m switching, say, from videos to the forum, almost every time. since the new site just recently was put up, i imagine a lot of bugs still need to be worked out. the player itself, when i’m watching a show, very occasionally, will show the play bar in the middle of a show without me moving the cursor or anything else. but that’s minor to the problems i was encountering before.


#29

Just as a datapoint, I am seeing the random log out issue too.

As for the new website, the big issue I have is that I can’t see a listing of all of the episodes for a show. The old version of the website listed every episode, including episodes that had not been released. The unreleased episodes would have a hoverbox that showed the release date. The new website only shows released episodes.


#30

I would like to report that http://theanimenetwork.com/ still doesn’t work, but http://www.animenetwork.com/ does.

If you’re using the HTTPS forced header however, it seems the server that the non www domain may not have anything running on port 80, and those that hit it the first time will think the site went down because their browser doesn’t think to switch to HTTPS (I have since removed the non www domain from my autocomplete list, hopefully, so this won’t be an issue for me)

DNS Info:

theanimenetwork.com 54.225.69.232
www.theanimenetwork.com 107.21.221.121 (Alias of ano-sso-prod.elasticbeanstalk.com)

#31

Thank you all for the reports and feedback this weekend! I’ve got some specific questions and responses for you all below. Thanks again for your patience while we work to resolve these issues.

@miquelfire - thanks for the updated info! Yes, it definitely looks like the system is mis-identifying your browser as being a desktop variety and not a mobile variety, leading it to offer the wrong player. This information is being relayed to the dev team to help with the fix.
Yes, we’re still working on the Domain issue. A lot of other issues a head of it on the list. Your information has been relayed. Please be sure to update your bookmarks to be http://www.theanimenetwork.com

@a_mailbox, @awsomejay2 - Thanks for your report and all of the details. They really do help. We’re currently tracking a bug that is causing problems for some of our Canadian and mobile users. We’re working on the fix. Thanks for you patience.

@rouguefox1 - thanks for the updated info. It’s a big help for us when tracing these issues that seem to be happening in one browser, but not another.

@Sensei_Terry_Silver - Thanks for your report. You are the first Mac user to report the logout issue, so that is very helpful.
As for the issue with getting the Bad Region message, can you confirm your country? We’re currently working on a bug that’s causing our Canadian users grief.

@8griever8 - Thanks for the details & the error message.

@pbisson - Thanks for the updated report!

@wdf12 - Thanks for the update!

@falingtrea - Thanks for the report! We have an improved Online Schedule on the site, so you can see what new episodes will be coming out in a consolidated place. We’ll add your feedback about displaying upcoming episodes on the series page to the suggestion list.


#32

I can now get to the episodes, so the bad region error seems to be fixed for me.

That said, i’ve ran into a new problem in that when i get to the episode (i’ve tried a few shows, some old some new) it tells me i can’t watch it because i’m not in the US (ie: the “hulu is only in the US” screen pops up)

I assume this shouldn’t be the case since, going by your responses, you wish to allow Canadians to use ANO as well.

I thought i should report regardless.

Edit: seems like teasers and stuff along those lines are watchable, but full episodes have the above issue.


#33

I’m getting the same error page, not when I log in, but rather when I try to select a video category, a particular list under the alphabetical search (e.g.: in the #-Z bar, when I select “K”), or when I type in the URL for the series in question (Kamisama Dolls, in this case). These same pages load just fine when I log out. I am also running Win 7 & Chrome. Also, if I open a link in a new tab, it forgets I’m logged in, so I have to log back in, go to the home screen, etc., etc., until I get to the page I wanted to open in the first place (and back arrowing to said page and refreshing logs me out again, unless that page is the home screen).

Addendum: this error is consistent; it happens every time, and refreshing doesn’t help.

Addendum #2: The login/new tab issue appears to be limited to Chrome for me. Just tried it on Maxthon, and though it keeps me logged in across tabs, as soon as the last tab for ANO closes, I get logged out. This is only a minor annoyance, though I would prefer my session remain active longer than that. More importantly, however, I still get the below error when I try to view a category/watch a video while logged in (again, in Maxthon browser).

On an unrelated note, could you use a source other than Hulu for premium members for the subbed versions? It rather defeats the purpose of being a premium member if you have to sit through commercials.

======================================================================================

Server Error in ‘/’ Application.

Object reference not set to an instance of an object.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:

Line 52: <button class="@Model.AddToQueueButtonClass addTitle@(title.Id) @(Model.Queue.Count(x => x.Id == title.Id) == 0?"":“hidden”)" onclick=“addTitleToQueue(@title.Id,’@SHA1Hash.SaltedHash(Model.User.Id.ToString()+title.Id.ToString())’);” title=“Add To Queue”>
Line 53: <button class="@Model.RemoveFromQueueButtonClass removeTitle@(title.Id) @(Model.Queue.Count(x => x.Id == title.Id) == 0?“hidden”:"")" onclick=“removeTitleFromQueue(@title.Id,’@SHA1Hash.SaltedHash(Model.User.Id.ToString() + title.Id.ToString())’);” title=“Remove From Queue”>
Line 54: <button class="@Model.AddFavoriteButtonClass addFavorite@(title.Id) @(Model.Favorites.Count(x => x.Id == title.Id) == 0?"":“hidden”)" onclick=“addFavorite(@title.Id,’@SHA1Hash.SaltedHash(Model.User.Id.ToString() + title.Id.ToString())’);” title=“Add Favorite”>
Line 55: <button class="@Model.RemoveFavoriteButtonClass removeFavorite@(title.Id) @(Model.Favorites.Count(x => x.Id == title.Id) == 0 ? “hidden” : “”)" onclick=“removeFavorite(@title.Id,’@SHA1Hash.SaltedHash(Model.User.Id.ToString() + title.Id.ToString())’);” title=“Remove Favorite”>
Line 56:

Source File: c:\inetpub\wwwroot\Views\Anime\TitlesByTag.cshtml Line: 54

Stack Trace:

[NullReferenceException: Object reference not set to an instance of an object.]
ASP.<>c__DisplayClass9.b__3(Title x) in c:\inetpub\wwwroot\Views\Anime\TitlesByTag.cshtml:54
System.Linq.Enumerable.Count(IEnumerable1 source, Func2 predicate) +153
ASP._Page_Views_Anime_TitlesByTag_cshtml.Execute() in c:\inetpub\wwwroot\Views\Anime\TitlesByTag.cshtml:50
System.Web.WebPages.WebPageBase.ExecutePageHierarchy() +279
System.Web.Mvc.WebViewPage.ExecutePageHierarchy() +125
System.Web.WebPages.StartPage.ExecutePageHierarchy() +142
System.Web.WebPages.WebPageBase.ExecutePageHierarchy(WebPageContext pageContext, TextWriter writer, WebPageRenderingBase startPage) +109
System.Web.Mvc.ViewResultBase.ExecuteResult(ControllerContext context) +379
System.Web.Mvc.ControllerActionInvoker.InvokeActionResultFilterRecursive(IList1 filters, Int32 filterIndex, ResultExecutingContext preContext, ControllerContext controllerContext, ActionResult actionResult) +108 System.Web.Mvc.ControllerActionInvoker.InvokeActionResultFilterRecursive(IList1 filters, Int32 filterIndex, ResultExecutingContext preContext, ControllerContext controllerContext, ActionResult actionResult) +890
System.Web.Mvc.ControllerActionInvoker.InvokeActionResultFilterRecursive(IList1 filters, Int32 filterIndex, ResultExecutingContext preContext, ControllerContext controllerContext, ActionResult actionResult) +890 System.Web.Mvc.ControllerActionInvoker.InvokeActionResultWithFilters(ControllerContext controllerContext, IList1 filters, ActionResult actionResult) +97
System.Web.Mvc.Async.<>c__DisplayClass21.b__1e(IAsyncResult asyncResult) +231
System.Web.Mvc.Controller.b__1d(IAsyncResult asyncResult, ExecuteCoreState innerState) +29
System.Web.Mvc.Async.WrappedAsyncVoid1.CallEndDelegate(IAsyncResult asyncResult) +111 System.Web.Mvc.Controller.EndExecuteCore(IAsyncResult asyncResult) +53 System.Web.Mvc.Async.WrappedAsyncVoid1.CallEndDelegate(IAsyncResult asyncResult) +19
System.Web.Mvc.MvcHandler.b__5(IAsyncResult asyncResult, ProcessRequestState innerState) +51
System.Web.Mvc.Async.WrappedAsyncVoid`1.CallEndDelegate(IAsyncResult asyncResult) +111
System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +606
System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +288

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.34212


#34

Quick update for all of you Canadian users:
We’ve done an update to fix the issue where the site was trying to give you the Hulu player.

Now, you have access to the guest & premium content (based on your account status) through the HTML 5 player.

Please let me know here if any of you continue to be served a broken player.

@a_mailbox, @Sensei_Terry_Silver, @awsomejay2


#35

UPDATE
Sorry for not providing a reply earlier.

Yes, I’m from Canada and yes, we’re ( unfortunately ) region blocked by Hulu.

I have done a few tests and I can now watch shows I have access to. Accessing to paid content give me an " Invalid Country" error instead of the " No Free Sub" page from this weekend.

It also seems I can stay logged in a tad longer but I keep getting logged out randomly. I can stay logged in long enough to navigate to an episode, but I’ll be logged out if I’m going back.

==========

Question : was there a change in the amount of content a “registered” user have access to ? Since I’m subscribing to a SVOD45 package, I mostly use the online player as a “back-up plan” on shows missing on a update – I could usually watch most subbed shows and those “Free Forever” dubs of older ADV releases ( like, say RahXephon ) , but now it seems I only have access to the first sub episode of a series.

Was are the differences now between a “Guest” and “Registered” user ?


#36

Are the “Invalid Country” and “No Free Sub” pages the same and prompting you to subscribe/start a free trial? If you are getting the terminology from the URL, at present, the URL isn’t an indicator of what the actual reason for the paywall page is. We’re still making adjustments to the error logging system.

Are you getting prompted to subscribe/login when trying to watch an episode that is labeled as Guest?


Guest and Registered are the same in terms of the content available. There is not a separate “registered” tier of content. A video either requires an active subscription to view, or else it doesn’t.


Yes, the offering for free content has changed. Due to licensing restrictions, we can only offer limited subtitled episodes from TV series for free viewing, without ads. Otherwise, a premium subscription is required.


#37

I’m a paid subscriber and haven’t been able to use the site since the new code went live. Every attempt to get near a show blows up the web browser, both Chrome and Firefox. Clicking on new releases, for example, gives this:

Server Error in ‘/’ Application.

Object reference not set to an instance of an object.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:

Line 52: <button class="@Model.AddToQueueButtonClass addTitle@(title.Id) @(Model.Queue.Count(x => x.Id == title.Id) == 0?"":“hidden”)" onclick=“addTitleToQueue(@title.Id,’@SHA1Hash.SaltedHash(Model.User.Id.ToString()+title.Id.ToString())’);” title=“Add To Queue”>
Line 53: <button class="@Model.RemoveFromQueueButtonClass removeTitle@(title.Id) @(Model.Queue.Count(x => x.Id == title.Id) == 0?“hidden”:"")" onclick=“removeTitleFromQueue(@title.Id,’@SHA1Hash.SaltedHash(Model.User.Id.ToString() + title.Id.ToString())’);” title=“Remove From Queue”>
Line 54: <button class="@Model.AddFavoriteButtonClass addFavorite@(title.Id) @(Model.Favorites.Count(x => x.Id == title.Id) == 0?"":“hidden”)" onclick=“addFavorite(@title.Id,’@SHA1Hash.SaltedHash(Model.User.Id.ToString() + title.Id.ToString())’);” title=“Add Favorite”>
Line 55: <button class="@Model.RemoveFavoriteButtonClass removeFavorite@(title.Id) @(Model.Favorites.Count(x => x.Id == title.Id) == 0 ? “hidden” : “”)" onclick=“removeFavorite(@title.Id,’@SHA1Hash.SaltedHash(Model.User.Id.ToString() + title.Id.ToString())’);” title=“Remove Favorite”>
Line 56:

Source File: c:\inetpub\wwwroot\Views\Anime\TitlesByTag.cshtml Line: 54

Stack Trace:

[NullReferenceException: Object reference not set to an instance of an object.]
ASP.<>c__DisplayClass9.b__3(Title x) in c:\inetpub\wwwroot\Views\Anime\TitlesByTag.cshtml:54
System.Linq.Enumerable.Count(IEnumerable1 source, Func2 predicate) +153
ASP._Page_Views_Anime_TitlesByTag_cshtml.Execute() in c:\inetpub\wwwroot\Views\Anime\TitlesByTag.cshtml:50
System.Web.WebPages.WebPageBase.ExecutePageHierarchy() +279
System.Web.Mvc.WebViewPage.ExecutePageHierarchy() +125
System.Web.WebPages.StartPage.ExecutePageHierarchy() +142
System.Web.WebPages.WebPageBase.ExecutePageHierarchy(WebPageContext pageContext, TextWriter writer, WebPageRenderingBase startPage) +109
System.Web.Mvc.ViewResultBase.ExecuteResult(ControllerContext context) +379
System.Web.Mvc.ControllerActionInvoker.InvokeActionResultFilterRecursive(IList1 filters, Int32 filterIndex, ResultExecutingContext preContext, ControllerContext controllerContext, ActionResult actionResult) +108 System.Web.Mvc.ControllerActionInvoker.InvokeActionResultFilterRecursive(IList1 filters, Int32 filterIndex, ResultExecutingContext preContext, ControllerContext controllerContext, ActionResult actionResult) +890
System.Web.Mvc.ControllerActionInvoker.InvokeActionResultFilterRecursive(IList1 filters, Int32 filterIndex, ResultExecutingContext preContext, ControllerContext controllerContext, ActionResult actionResult) +890 System.Web.Mvc.ControllerActionInvoker.InvokeActionResultWithFilters(ControllerContext controllerContext, IList1 filters, ActionResult actionResult) +97
System.Web.Mvc.Async.<>c__DisplayClass21.b__1e(IAsyncResult asyncResult) +231
System.Web.Mvc.Controller.b__1d(IAsyncResult asyncResult, ExecuteCoreState innerState) +29
System.Web.Mvc.Async.WrappedAsyncVoid1.CallEndDelegate(IAsyncResult asyncResult) +111 System.Web.Mvc.Controller.EndExecuteCore(IAsyncResult asyncResult) +53 System.Web.Mvc.Async.WrappedAsyncVoid1.CallEndDelegate(IAsyncResult asyncResult) +19
System.Web.Mvc.MvcHandler.b__5(IAsyncResult asyncResult, ProcessRequestState innerState) +51
System.Web.Mvc.Async.WrappedAsyncVoid`1.CallEndDelegate(IAsyncResult asyncResult) +111
System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +606
System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +288

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.34212


#38

@mr_protocol - Thanks for your report and the error message - it really helps! We’re already working on this bug. We’ll update you when it’s resolved.


#39

I’m still getting the Hulu player, (Watching Modern Magic Made Simple; using Chrome.) And being Hulu, it’s still serving up commercials. I’m an ANO premium subscriber, so I shouldn’t have to sit through commercials

Update:
Ah, I notice that update was aimed at Canadians, though, so maybe a similar patch hasn’t been implemented for US users?

Second update:
I just discovered that, although it was showing me as logged in, I actually wasn’t, and when I do log in, I get the error page I’d been getting earlier. I don’t know if the error is verbatim the same, as it’s too much code for me to read through and I don’t understand anything beyond “Server error in ‘/’ Application” (actually, to be more accurate, I don’t understand even that much.)


#40

@Jerran -
Sorry to hear you are having this issue. This is not a known bug for US subscribers since you are always supposed to be getting our Premium player.

Can you confirm that you are still signed in when you get served up the Hulu player? It could be that you have fallen victim to the bug that is causing users to be randomly signed out when they move around on the site. If you get signed out as you are moving towards a watch page, that would explain why you are not getting the premium player.

Please let me know if this is what is happening to you. Otherwise, I’ll need to do further testing on your account.